Cult of the Lamb Switch NSP + Update 1.0.3 + DLC (eShop)

Cult of the Lamb Switch NSP

Title: Cult of the Lamb
Release Date: Aug 11, 2022
Category: Action, Strategy
Publisher: Devolver Digital
Type: eShop
Format: NSP
Title ID: 01002E7016C46000
Title Size: 783 MB
Language: En, De, Es, Fr, Ja, Pt, Ru, Zh
Required Firmware: 14.1.0
CFW: 14.1.0 + Atmosphere 1.3.2

Cult of the Lamb NSP start your own cult in a land of false prophets, venturing out into diverse and mysterious regions.

Description: Collect and use resources to build new structures, perform dark rituals to appease the gods, and give sermons to reinforce the faith of your flock. Explore a sprawling, randomly generated world, fight off hordes of enemies and defeat rival cult leaders in order to absorb their power and assert your cult’s dominance. Train your flock and embark on a quest to explore and discover the secrets of five mysterious regions. Cleanse the non-believers, spread enlightenment and perform mystical rituals on the journey to become the mighty lamb god.

How to Install the Game

  1. Install the NSP via Tinfoil, or DBI Installer.
  2. Once installations is done play and Enjoy the game.

Tested Screens

Download Links

Base Game NSP (783 MB)

1Fichier
Download

HexUpload
Download

MegaUp
Download

Google Drive
Download

DLC Pack (2 DLCs)

Update 1.0.4 (v262144)

Please report the broken/dead/missing links into the comment section.

guest

105 Comments
Newest
Oldest Most Voted
Inline Feedbacks
View all comments
Lukas
Lukas
17 days ago

Hi, thanks for your upload. Sadly, i cant start the sowftware. It says, that it requires Internet connection, and i wont start, if i press cancel. When im connectet to the Internet (my switch is banned), it wont start either. Even if I wati a few minutes. Is there any workaround?

Ratta777
Ratta777
20 days ago

Hi Admin! Can you add this game please? Thank You 😀
Link: https://www.nintendo.com/es-mx/store/products/aca-neogeo-the-king-of-fighters-2002-switch/

Cambrode
Cambrode
23 days ago

I updated the game but still shows 1.0.1 on top. Is that okay?

Faisal
Faisal
28 days ago

I have a problem… the game appears in English with no option to change it.

HalfScoper
HalfScoper
27 days ago
Reply to  Faisal

The only problem you have is not being able to read the whole comment section, I explained it down below already.
https://nxbrew.com/cult-of-the-lamb-switch-nsp-eshop/#comment-97257

Faysal
Faysal
28 days ago

When I start the game it appears that I have v1.0.1

Taku
Taku
28 days ago

Thank you for the new update 🙂

Shmity
Shmity
29 days ago

Love you.

Dennis Cambronero
Dennis Cambronero
29 days ago

Is the dlc 2 the same as the update?

JJJJJJJJTTTTTT
JJJJJJJJTTTTTT
27 days ago

no; current patch is 1.0.3 redownload and install

fixes a huge amount with lag and save lag

Cordero
Cordero
29 days ago

: I really admire your patience;-) Thanks for keeping the toddlers entertained!

HalfScoper
HalfScoper
29 days ago
Reply to  Cordero

Yeah look at all those fucking “uPdAtE 1.0.3 iS oUt” retards.

Andre
Andre
29 days ago

Have a new update 1.0.3

Modest
Modest
29 days ago

Where is the 1.0.3 update?

PreviouslyFruition
PreviouslyFruition
29 days ago
Reply to  AdminNx

Thanks for the DLC! That’s not the new update, FYI.

The DLC is a new skin (“follower form”) with a Cthulhu theme

It looks like like Patch 1.0.3 was released yesterday or today, according to

(Developer Twitter) https://twitter.com/cultofthelamb/status/1562482118336270338

Last edited 29 days ago by PreviouslyFruition
HalfScoper
HalfScoper
28 days ago

Wrong, the Cthulhu form is DLC 1.
The second DLC unlocks the following forms:

  • Monke
  • Tapir
  • Bee
  • Narwhal
  • Tortoise
  • Pretty flower decorations
cgr
cgr
29 days ago

Hi, I’m having a problem with the update, and it’s that when I install it, although from the switch menu it says that I’m on 1.0.2, in the game it tells me that it’s on 1.0.1, I’m on version 14.1.2 and the AMS is 1.3.2

The BID does not change from version 1.0.2 either

akitafriend
akitafriend
29 days ago
Reply to  cgr

Are you connected to Nintendo’s servers or anything? Technically the latest update (1.03) is actually a downgrade to 1.01 (it will display as 1.01 internally when you open the game) and it shouldn’t be possible for you to get it unless you got it from Nintendo somehow because I don’t think it’s up anywhere. Just letting you know if that’s where you’re seeing the 1.01 from, technically that is the newest patch. They had to downgrade us one patch because the day 1 patch (1.02) is where most bugs came from. The patch is called 1.03 by Nintendo and 1.01… Read more »

Last edited 29 days ago by akitafriend
HalfScoper
HalfScoper
29 days ago
Reply to  cgr

Normal, it’s a visual bug, everybody has that.

Rorri
Rorri
30 days ago

Hola, salio la versión 1.0.3 la podrias subir?

a2@a.com
30 days ago

Please upload the updateds!
the endgame crashes

Rorri
Rorri
30 days ago

There is a new update 1.0.3
Can update it?

shikikan
shikikan
30 days ago

1.0.3 is up

Ing. Erik Perez Perez Gonzalez
Ing. Erik Perez Perez Gonzalez
30 days ago

Que onda viejito, fijate que me sale un error de “Version demasiado baja” Alli, que tengo que actualizar? ya lei que son los sigpathes pero…. tambien tendria que actualizar el atmosphere?

Ing. Erik Augusto Perez Gonzalez
Ing. Erik Augusto Perez Gonzalez
28 days ago
Reply to  AdminNx

La version actual dice que es 13.0.0 y AMS 1.3.0/S
Chales, quise descargar Pacman y tampoco me dejo D:

Ing. Erik Augusto Perez Gonzalez
Ing. Erik Augusto Perez Gonzalez
27 days ago
Reply to  AdminNx

Que onda viejito, nada mas para quien lo necesite, Actualize mi version del switch a la 14.1.2 y y el AMS al 1.3.2/S y sin problema ya me dejo instalar los videojuegos

JJJJJJJJTTTTTT
JJJJJJJJTTTTTT
30 days ago

any ETA on patch 1.0.3 being uploaded? TIA

akitafriend
akitafriend
1 month ago

Update is out! 1.0.3, thanks for keeping these games up to date!

Last edited 1 month ago by akitafriend
Shensil
Shensil
1 month ago

Hey, thanks for the game. I launch the game easily, but i have an issue with shaders, the decor with sun on it is pixelated, any solution ?

Vayne
Vayne
1 month ago

torrent?

Vincent
1 month ago

Hello.

Any way to get patch 1.0.5?

Thanks

Last edited 1 month ago by Vincent
Vincent
1 month ago
Reply to  AdminNx

I think is 1.0.5 or .6, but it was release Aug 15. But I can be wrong.

shikikan
shikikan
1 month ago
Reply to  Vincent

we have to wait first for nintendo to allow the update.

a2@a.com
1 month ago

this game is awesome, love to grow my cult

catesby
catesby
1 month ago

thanks a lot, really enjoyed the game

Julian
Julian
1 month ago

Hay alguna forma de instalarlo con el USBloader?

shikikan
shikikan
1 month ago
Reply to  Julian

Usa tinfoil o DBI, si tratas con awoo puede que falle, últimamente no sirve.

Alejandro
Alejandro
1 month ago

Buenas tardes, los links de google drive se han caído :c

jessika
jessika
1 month ago

404. That’s an error.

The requested URL was not found on this server. That’s all we know.
the link for base game /google drive message when clicked >>

Julius Tran
Julius Tran
1 month ago

works for fw13.1

THX
THX
1 month ago

Status Aug. 13. 8PM: >>> It works. Bevor not.

Dormamu
Dormamu
1 month ago

Currently, patch 1.0.2 causes input lag and framerate issues for some Switch users. For the time-being, it is recommended to stay on the base version.

HalfScoper
HalfScoper
1 month ago
Reply to  Dormamu

… or you could just overclock a little with sys-clk and play the latest version without any problems.

TATA
TATA
1 month ago

Torrent possible?

luis ismael
luis ismael
1 month ago

Hello, an apology, I try to install the game but it tells me that a file is damaged, what can I do?

Kin Daoud Carder
Kin Daoud Carder
1 month ago
Reply to  AdminNx

I have the same issue, it says “An error occurred : cannot extract entry : Pokemon Legends Arceus[01001F5010DFA000][US][v0].nsp”

JBridge
JBridge
1 month ago
Reply to  AdminNx

I had this and updated my Atmosphere and Patches and then it worked fine.

sergio camacho
sergio camacho
1 month ago

hola, admin
me pide que desactive el modo avion y que configure el acceso a internet para poder abrir el juego, de ahi no me deja pasar

Victor
Victor
1 month ago

The game does have portuguese but only opens in english.

HalfScoper
HalfScoper
1 month ago
Reply to  Victor

You can try to force the language with DBI: rashevskyv/dbi: Author is duckbill (github.com)

  • Browse installed applications
  • Press A on Cult of the Lamb
  • Select the base version with X
  • Press + and select “Force language”
  • There you can choose Portuguese, if it’s available. If not, it’s not included in the game files.
Brian
Brian
1 month ago

Hi admin, the link is not working.

Renjun
Renjun
1 month ago

Hey admin the link is messed up I click the pixeldrain and it opens the megaup link and when I try the mega up link it opened up hexfile

Dave
Dave
1 month ago

Hello, may I know where to get the Prod Key for Cult please? Thanks!

Dave
Dave
1 month ago
Reply to  AdminNx

Yes sir! Thanks

Sulldog
Sulldog
1 month ago
Reply to  Dave

google it, easy to find “prod keys yuzu”

Dave
Dave
1 month ago
Reply to  Sulldog

Already had it working, end up downloading a different file. Didn’t need new keys… just had an updated firmware

Skat
Skat
1 month ago

I´m trying to run the game but it needs a linked Nintendo account. I tried by Linkhalo and Tinfoil but it´s not working.
Thanks for the upload!!

Angel
Angel
1 month ago
Reply to  AdminNx

when I close the message the game don´t run, and don´t matter how much I try

Belzac
Belzac
1 month ago

Stuck on Cheaking if the software can be played….

Yzard
Yzard
1 month ago
Reply to  AdminNx

So this dump don’t work 100% or I can try to install?

aresu
aresu
1 month ago
Reply to  AdminNx
but it doesn't work for me either
paper
paper
1 month ago
Reply to  AdminNx

Same issue. Has an updated dump been uploaded? Thanks

Nicolo
Nicolo
1 month ago
Reply to  AdminNx

Hi, i have FW 14.1.2 and AMS 1.3.2, also updated sigpatches but can`t play the game because it say to disable airplain mode or ask for a internet connection, what i should do? thanks