DRAGON BALL Z: KAKAROT + A NEW POWER AWAKENS SET Switch NSP + Update + DLCs [EUR/ASIA/JPN]

DRAGON BALL Z: KAKAROT + A NEW POWER AWAKENS SET Switch NSP

Title: DRAGON BALL Z: KAKAROT + A NEW POWER AWAKENS SET
Release Date: Sep 24, 2021
Category: Action, RPG
Publisher: BANDAI NAMCO
Type: Physical
Format: NSP
Title ID: 0100FD70134FA000
Title Size: 12.9 GB
Language: En, Fr, De, It, Es, Pt, Ru, Ko, Tw, Zh, Ja
Required Firmware: 12.1.0
CFW: 12.1.0 + Atmosphere 0.19.0

DRAGON BALL Z: KAKAROT + A NEW POWER AWAKENS SET NSP relive the story of Goku and other Z Fighters in DRAGON BALL Z: KAKAROT!

Description: Experience the story of DRAGON BALL Z (드래곤볼 Z 카카로트 + 새로운 각성 편) from epic events to light-hearted side quests, including never-before-seen story moments that answer some burning questions of DRAGON BALL lore for the first time! Play through iconic DRAGON BALL Z battles on a scale unlike any other. Fight across vast battlefields with destructible environments and experience epic boss battles against the most iconic foes (Raditz, Frieza, Cell etc.). Increase your power level through RPG mechanics and rise to the challenge!

How to Install the Game

  1. Install the NSP via TinfoilAwoo Installer or Gold Leaf.
  2. Once installations is done play and Enjoy the game.

Download Links

Region Asia [0100FD70134FA000] [Ko, Tw, Zh]

Base Game NSP (12.9 GB) (Converted NSP)

1Fichier
Part1, Part2, Part3

FastDrive
Part1, Part2, Part3

Mediafire
Part1, Part2, Part3

MegaUp
Part1, Part2, Part3

Google Drive
Part1, Part2, Part3

Torrent
Download

Update 1.11 (v131072)

Region Europe [010051C0134F8800] [En, Fr, De, It, Es, Pt, Ru]

Base Game NSP (12.9 GB) (Verified NSP)

1Fichier
Part1, Part2, Part3

HexUpload
Part1, Part2, Part3

MegaUp
Part1, Part2, Part3

Google Drive
Part1, Part2, Part3

Torrent
Download

Update 1.11 (v131072)

Region Japan [0100EF00134F4000] [En, Ja]

Base Game NSP (12.9 GB) (Converted NSP)

1Fichier
Part1, Part2, Part3

MegaUp
Part1, Part2, Part3

Google Drive
Part1, Part2, Part3

Torrent
Download

DLC Pack (11 DLCs)

Update 1.11 (v131072)

Please report the broken/dead/missing links into the comment section.

guest
191 Comments
Newest
Oldest Most Voted
Inline Feedbacks
View all comments
Revil
Revil
4 months ago

Thanks dbz europe ver. game, dlc and update working great on sxos fw 11.

alex80san
alex80san
4 months ago
Reply to  Revil

No, not working, software closed because of an error occured

runset
runset
4 months ago
Reply to  Revil

the jp ver also working fine. using Sxos on fw 11.0

AJbvvvvvv
AJbvvvvvv
3 months ago
Reply to  Revil

Working on fw 11 sxos here too

Kors
Kors
1 month ago

Japan Version ,MegaUp and Google Drive have no file in it

Rizki
Rizki
1 month ago

Im download asia region it using Chinese language 🙁 where region using English language??

DavZ
DavZ
3 months ago

Yep, install the base game, update and dlc with “awoo installer 1.3.4”, work fine, my switch 12.03AMS M19.
Thanks AdminNX for the job.

Tristan Sarmiento
Tristan Sarmiento
3 months ago

Update 1.10 for Japan Region Link not working

WXX
WXX
3 months ago

HI, does region Asia one got DLC?

WXX
WXX
3 months ago
Reply to  AdminNx

Thank you for replying

hope
hope
3 months ago

does the europe version have japanese voice and japanese soundtrack?

Noxx
Noxx
3 months ago

Doesn’t work. Software closed because of an error 🙁
I tried to install it with and without update. Both didn’t work…

Steven
Steven
3 months ago

aun no sale este juego en vercion americana?

Maja rakan
Maja rakan
3 months ago

Hey admin
The game and update installed without a hitch but there seems to be a problem with the dlc , says too low firmware or sign patches
I am firmware 13.0 and latest signpatches

Tarekmourad
Tarekmourad
3 months ago
Reply to  AdminNx

gold leaf
tinfoil
tin leaf
all give an error

Tarekmourad
Tarekmourad
3 months ago
Reply to  AdminNx

europe , NCA error 2002-4518(0x234C02) too low firmware or signpatches ,
firmware 13.0.0 ams 1.1.1.

Tarekmourad
Tarekmourad
3 months ago
Reply to  AdminNx

tried but to no avail i updated the patches and tried tinleaf and enabled skip nca check but still says nca error low sigpatches
is there a manual way to bypass it ?
thanks in advance

Tarekmourad
Tarekmourad
3 months ago
Reply to  AdminNx

i have goldleaf, tinfoil ,lithium ,awoo and tinleaf
all install game and update but refuse the dlc
funny thing is activating bypass nca check never yields results in any of them

Ryu
Ryu
2 months ago
Reply to  Tarekmourad

arramca la switch desde el fuse primary y podras instalarlos

dixx
dixx
3 months ago

can you upload darksiders 3

Kazaputas42
Kazaputas42
3 months ago

EL JUEGO MAS ABURRIDO DE DRAGON BALL

RedHair
RedHair
3 months ago

I cant install the base game in tinfoil version 13 it say NCA signature verification failed in gold leaf I can install but dint work it say software closed because of an error occured…. i already update my firmware to 13.0.0 atmosphere 1.1.0 not working too in 12.1.0 atmosphere 0.19.0

Levi
Levi
3 months ago

I am using FW 12.1 Atmosphere 0.19.5, Latest : Awoo, Gold Leaf, Tinfoil. Still can’t install DBZ Kakarot -_-‘

Levi
Levi
3 months ago
Reply to  AdminNx

Tankyou Joker

Levi
Levi
3 months ago
Reply to  AdminNx

Base Game NSP (12.9 GB) (Verified NSP) worked.
But DLC and Update didnt work.

Dzeka
Dzeka
3 months ago

Any news on US version please
Thanks

mimi
mimi
3 months ago

can we get XCI version in torrent download

sarakira
3 months ago

can you upload asia version dlc? please

Gus GC
Gus GC
3 months ago

Works great! Thanks admin. Install base game and update on Tinfoil then DLC using Goldleaf and it should work.

Johann
Johann
3 months ago

Switch 11.0.1|AMS M19.5|S Funcionando perfectamente XCI base instalado por awoo, update 1.11 NSP por Goldleaf y DLC por Goldleaf, confirmo sin errores y jugando sin problemas, Gracias AdminNx

Kyo El Modisto De Consolas Retro
Kyo El Modisto De Consolas Retro
3 months ago

I try to install and reinstall the game but same massage appear “software closed because of an error occured” system 13.0.0 AMS 1.1.1 |S, Im using latest version of goldleaf as always but nothing works. What could be the problem?

Kyo El Modisto De Consolas Retro
Kyo El Modisto De Consolas Retro
3 months ago
Reply to  AdminNx

That solved the problem, now is working great thanks admin!

Dzeka
Dzeka
3 months ago

Still no USA region??

SomeGuyFromTH
SomeGuyFromTH
3 months ago

Hi can you upload the DLC Pack for Asia Version? it’s has Thai language for me so I want to play that version. Thanks!

Roberto
Roberto
4 months ago

Funcionando en FW: 13.0.0 / AMS 1.1.1/S
Version europea.

Graciassss, juegazo

Kyo El Modisto De Consolas Retro
Kyo El Modisto De Consolas Retro
3 months ago
Reply to  Roberto

A mi no me funciona y estoy en el mismo sistema de FW y AMS que tu, me aparece un mensaje de error y no abre el juego, como lo instalaste?

George
George
4 months ago

its weird, some people says working and some don’t, I am too. from yesterday night until now I give it a try from 12.1.0 + ams 0.19.0 until 13.0.0 + ams 1.1.1. added,deleted and replaced ams,bootloader,switch folder nothing working. install and delete the game many times, try without dlc, update just the base the result is the same “software closed because of an error occured”. (JP) version.

AJbvvvvvv
AJbvvvvvv
3 months ago
Reply to  George

Then try another version or use tinfoil to install the game

Maffu
Maffu
4 months ago

Hi I downloaded the European ver. of the game on ams 1.1.0 and switch ver. 13.0.0 I tried installing it through goldleaf with the dlc, game and update and I got an error message and I even tried reinstalling it without the dlc and got the same result how do I fix this I’m fairly new to this kind of stuff

Maffu
Maffu
4 months ago
Reply to  AdminNx

I updated the sigpatches to 1.1.1 and just installled the game and update and I’m still getting the error message is there anything else I can try?

Maffu
Maffu
4 months ago
Reply to  AdminNx

13.0

Maffu
Maffu
4 months ago
Reply to  AdminNx

I figured out the problem I was downloading all the files through gold leaf but I downloaded the base game and update through tinfoil and installed the dlc through gold leaf everything is now working on ams ver. 1.1.1 switch ver. 13.0.0 thank you

Luis
Luis
4 months ago

I have problems installing the dlc files. I got the next error message: “This file is a garbage fake file, that may even brick your switch… and should be deleted.” I am installing the Europe version with tinfoil.

Luis
Luis
4 months ago
Reply to  AdminNx

Problem solved. I had to update Tinfoil to version 13.0. It is working now. I had similar issue with the game Lost in Random, but the tinfoil update solved all these problems. Thanks admin.

Ozzy
Ozzy
4 months ago

tried installing Europe verison on FW 13.0 + AMS 1.1.0 and it says software closed because of an error, I installed the base game only but it had me install the update did that and it still gave me error but the first time I installed it I installed Base Game, Update and DLC, used Goldleaf to install.

Is there any fix for this?

Ozzy
Ozzy
3 months ago
Reply to  AdminNx

yes updated to AMS 1.1.1 and updated Sigpatches same error.

I saw a comment that they installed via tinfoil base game and update and dlc through goldleaf and worked so going to try that and see if it works

Missingno
Missingno
4 months ago

Instale la versión EU en mi consola 13.0.0, ams 1.1.1 con goldleaf y sale error al inicio …. “Se ha cerrado programa a causa de un error”

Juan
Juan
4 months ago

Sirve en la Version 12.0.1 con los dlcs y actualizaciones?

SergioGRX97
SergioGRX97
4 months ago

A los que les de problemas en instalar deben entrar a cualquier juego presionando R, yo lo instale por Awoo Installer 🙂 funcionando muy bien en 12.1 y Atmos 19.5

nepe
nepe
4 months ago
Reply to  SergioGRX97

Gracias, funciono de esa forma

Bardock Obama
Bardock Obama
4 months ago

Admin please help bro.. EU version not working. Software closed because error occured. Installed base game and updates and DLC via goldleaf 0.9.0. FW 12.1.0, AMS M.19.5 E

Tarekmourad
Tarekmourad
4 months ago
Reply to  Bardock Obama

u cannot install converted nsp through goldleaf , it can only install the nintendo shop vanilla versions , when they are available the admin will upload them , i am waiting myself 😀

elit
elit
4 months ago
Reply to  Bardock Obama

yo también lo instale con goldleaf 9.0 y me dio error despues de abrirlo.. Voy a probar con awoo installer a ver si me funciona. A veces solo es probar con diferentes intaladores para ver si te jalan un juego en concreto

rtyui
rtyui
4 months ago
Reply to  Bardock Obama

firmware 13.0.0 y Atmosphère 1.1.0 funciona y con la actualizacion y dlc´s con awoo installer

Last edited 4 months ago by rtyui
Alexander
Alexander
4 months ago

ya esta en español latino ?

Juan augusto
Juan augusto
4 months ago

Primero muchisimas gracias por compartir tengo algunas dudas en la pagina de tinfoil dice que el juego tiene key generation 11.0.0 y aca esta en 12.1.0 yo uso sxos y no voy a poder jugar, no habra el juego en firmware 11 porfavor

King_sparty
King_sparty
4 months ago

I cant get EU version to work. It says software closed because an error. Am on Fw13.0 + AMS 1.1.1 and installed update.

Chris "Mario" Pratt
Chris "Mario" Pratt
4 months ago
Reply to  King_sparty

yeah same, did you find a fix or?

King_sparty
King_sparty
4 months ago

no

Gintoki
4 months ago

Try updating sigpatches?
Im on fw 13.0 Ams 1.1.0 maybe you should downgrade your cfw

Lexz
Lexz
4 months ago

Cuando sale la versión americana ?

Lexz
Lexz
4 months ago
Reply to  AdminNx

Es que quiero descargar la versión americana, cuando sale o montas la versión americana ?

Eduardo
Eduardo
4 months ago

Instale el juego en una switch de mi hermano version 11.0.1 y en el mio switch 13.00 fue la version europea y no inicia el juego da error que puede ser ?

Prince Vegeta
Prince Vegeta
4 months ago

Hello admin is it worth waiting for US release or is EU release the same? I live in US

karma313
karma313
4 months ago

El juego no inicia, me descargué e instalé el juego base de la versión europea y no inicia, probé de nuevo junto con la actualización y seguía sin funcionar. Mi consola está en la versión 12.1.0 con CFW Atmosphere 0.19.5

Bardock Obama
Bardock Obama
4 months ago
Reply to  AdminNx

I tried both DBI and Tinfoil and neither worked 🙁

Bardock Obama
Bardock Obama
4 months ago
Reply to  AdminNx

I just tried this and still doesn’t work 🙁

yber
yber
4 months ago

both EU+JP not working on atmosphere 12.1 can anyone please advise ? error “could not start the software”

Yber
Yber
4 months ago
Reply to  AdminNx

Yes and nothing

dopenloco
dopenloco
4 months ago
Reply to  yber

update the signpatches too..its working for me..I’m on CFW 12.1.0 Atmosphere 19.5

dopenloco
dopenloco
3 months ago
Reply to  AdminNx

Japan..havent tried other region

Kenjiro
Kenjiro
4 months ago

update v1.11 takes me to 1fichier with this title “DRAGON BALL Z KAKAROT + A NEW POWER AWAKENS SET (NSP) (JP)” also works for the European version?

Nosbi
Nosbi
4 months ago

Is the DLC JPN package compatible with other regions?

Nosbi
Nosbi
4 months ago

is the JPN DLC pack worked for other regions?

Yepp
Yepp
4 months ago

I can confirm this is working on 10.0+without dlc and update. I hope this makes you guys happy. JPN version.

IMG20210924160309.jpg
Last edited 4 months ago by Yepp
Mark Brian
Mark Brian
4 months ago
Reply to  Yepp

You can also install the DLC. Thats fine.

tonynatha
tonynatha
4 months ago

Buen aporte. Podria subir si esta disponible Genshin Impact.

poopy
poopy
4 months ago

will we get a non converted version?

poopy
poopy
4 months ago
Reply to  AdminNx

jpn/english

i havent tried installing it yet. just that from past experience when using converted nsp i have encountered like some kind of warning when installing through awoo. i cant remember the whole thing but it goes something like “cannot verify this XXXXX do you still wanna continue to install?”

Donut
Donut
4 months ago

Does the JPN version includes the “Warrior of Hope” Trunks DLC?

Miguel
4 months ago

Gente aqui esta dbz kakarot usa versión pesa 15gb

Jer
Jer
4 months ago

The JPN Version allows you to chose ENG voices and text just so you guys know

kori08
kori08
4 months ago

Hello, does the update requires firmware 12? Or is it patched?

dantezteam
dantezteam
4 months ago

alguna contiene español latino ?

Yepp
Yepp
4 months ago

Does to game work JPN on fw 10.0+ ? Can anyone confirm?