Sid Meier’s Civilization VI Switch NSP + Update 1.2.7 + DLC + Expansion Pack

Sid Meier’s Civilization VI Switch NSP

Title: Sid Meier’s Civilization VI
Release Date: Jul 12, 2018
Category: Puzzle, Strategy
Publisher: 2K Games
Format: NSP
Title ID: 010044500C182000
Title Size: 4.89 GB
Language: En, Fr, De, It, Es, Pt, Ru, Ko, Zh, Ja
Multiplayer: Up to 2 players
Required Firmware: 6.2.0
CFW: 6.2.0 + Atmosphere 0.8.7

Sid Meier’s Civilization VI NSP is a turn-based strategy 4X video game developed by Firaxis Games, published by 2K Games.

Description: Originally created by legendary game designer Sid Meier, Civilization is a turn-based strategy game in which you attempt to build an empire to stand the test of time. Explore a new land, research technology, conquer your enemies, and go head-to-head with history’s most renowned leaders as you attempt to build the greatest civilization the world has ever known. And now on Nintendo Switch, the quest to victory in Civilization VI can take place wherever, whenever. Civilization VI for Nintendo Switch includes the latest game updates and improvements and four pieces of additional content which adds four new civilizations, leaders, and scenarios:

The path to victory is the one you determine. Become the most scientifically advanced civilization, dominate through sheer military power, or become the foremost destination for the cultural arts. See the marvels of your empire spread across the map. Settle in uncharted lands, improve your surroundings, build new districts, and see your cities – and your civilization – prosper. Unlock boosts that speed your civilization’s progress through history. To advance more quickly, use your units to actively explore, develop your environment, and discover new cultures.

How to Install and Update the Game

  1. Uncompress the files.
  2. Install the NSP file via TinfoilAwoo Installer or Gold Leaf.
  3. Once all installations are done play and Enjoy the game.

Download Links

Torrent Link

NSP + Update + DLC + Expansion Pack
Download

Base Game NSP (4.89 GB)

1Fichier
Download

MEGA
Download

Google Drive
Download

Expansion Pack (3.56 GB)

DLC Pack (10 DLCs)

Update 1.2.2 (v52488)

New Update, Expansions Files, and DLCs

  1. Update 1.2.5 and update 1.2.6 that they are NOT compatible with the current Rise and Fall + Gathering Storm Expansion Pack.
  2. Below updated Expansion Pack is only compatible with 1.2.4 and NOT with higher versions at this moment.
  3. It is recommend the use of Goldleaf or DBI to reset the game version so you are able to start 1.2.4 even if you have installed 1.2.5 or higher before.
  4. Review some of stickied comments to see whether they should still be stickied.

Expansion Pack (Updated)

Maya & Gran Columbo Expansion (Updated)

New Frontier Pack

Update 1.2.4 (v786432)

Updates/DLCs September 2020 Release

Following are the DLCs added/updated on 27th September 2020.

DLC Pack (September 2020)

Expansion Pack (Updated) (September 2020)

Update 1.2.7 (v851968)

Please report the broken/dead/missing links into the comment section.

guest
272 Comments
Newest
Oldest Most Voted
Inline Feedbacks
View all comments
Jumbuleo
Jumbuleo
2 months ago

@AdminNx: Could you please do the following?: -Add a description to update 1.2.5 and update 1.2.6 that they are NOT compatible with the current Rise and Fall + Gathering Storm Expansion Pack. -Add a description to the updated Expansion Pack that it is only compatible with 1.2.4 and NOT with higher versions at this moment. -That at this moment only Part 1 of the New Frontier Pass is available to the community and that while Parts 2 and 3 have been released through official ways, their updated nsps are nowhere to be found yet. -Recommend the use of Goldleaf or… Read more »

taeteodoro
taeteodoro
2 months ago
Reply to  AdminNx

no hubo upate de expansion pack , excepto eso funciona todo ok con 1.2.7. ahora como no hubo expansion pack update , genera error de mod. gracias por tu esfuerzo.

Jumbuleo
Jumbuleo
2 months ago
Reply to  AdminNx

Thank you so much for the effort and for the upload of 1.2.7 and the September DLC! That was quick! I have yet to test it, but my guess is that people can now choose to either install and go with:
A) 1.2.4 with Updated Expansion Pack and New Frontier Pass Part 1 (Maya and Gran Colombia).
B) 1.2.7 without Expansion Pack, but with September DLC.
The old Scenario Pack of Indonesia, Khmer and Nubia will probably work either way.

Vinrael
Vinrael
2 months ago
Reply to  AdminNx

Hey Admin, thanks for the great work. Is there any ETA on the expansion pack that is updated for 1.2.7?

Arths91
Arths91
2 months ago
Reply to  Jumbuleo

Hi, I am playing the 1.2.4 set of dlc. The nubia pack alone does not work for me. It does not allow game to boot all other dlc work fine. Does Nubia work for you?

I am on sx 3.0.5 and ofw latest. I tried nubia from here and 2 other sites (122kb, 124kb and 154 kb files from 2019 and 2020.)

Son Goku
Son Goku
3 months ago

Just a warning, if you install update 1.2.6 once, you won’t be able to play the provided Expansion Pack anymore unless you factory reset your Switch.

As others mentioned, the updated Expansion Pack is probably for 1.2.4, and if you install a higher version of the game once, the Switch will refuse to ever boot a lower version of it, even if you clean install the game again. I recommend removing the link for 1.2.5 and 1.2.6 as playing with the Expansion Pack is important for this game. Thanks for your work.

Jumbuleo
Jumbuleo
3 months ago
Reply to  Son Goku

Correct, but factory reset is not necessary. Search for DBI installer or Goldleaf and for their capabilities to reset the version of the game.

Everton
Everton
2 months ago
Reply to  Jumbuleo

Hey man. I used Goldleaf to reset the game version to 1.0, but it stills gives me an error asking to update the game every time I try to launch it. Any tips? The version I have installed now is the 1.2.4 (previously I had the 1.2.6 that is messed up)

Also I tried applying both Expansion Packs (updated) from the links above, but the game still refuses to launch asking for a update.

Catsanddogs
Catsanddogs
2 months ago
Reply to  Everton

Look up devmenu, install the nsp then use that program to reset the launch version of the game or something along those lines. You need the 6.x+ version and you need to downgrade your firmware to 9.2.0 or lower. This fixed the problem you encountered for me and allowed me to play 1.2.4

Ricardo Linares
Ricardo Linares
3 months ago
Reply to  Son Goku

You can use DBI.nro from NSC_Builder Github to reset the required version of the game, so no need te reset your switch.

Lethi
Lethi
2 months ago
Reply to  Son Goku

So optimal install order is the following then?

  1. Base Game
  2. Expansion Pack (updated)
  3. DLC Pack (10 DLC’s)
  4. Maya & Gran Columbo Expansion (Updated)

and leave the 2 latest updates out of the install?

patientx
patientx
2 months ago
Reply to  Lethi

Did it work for you with this order ? You can play every expansion civ etc ?

Jumbuleo
Jumbuleo
2 months ago
Reply to  patientx

Order does not matter, compatibility between nsps matters. And this means that the versions of the DLC here will only work with game version 1.2.4, so install that version and not 1.2.5 or 1.2.6

Nice job
Nice job
2 months ago
Reply to  Son Goku

Thank you kakarot for your wisdom and thank you admin for the sticky, not to mention everything else you do for us all.
You guys rock

edgar2656
edgar2656
4 months ago

Hola
Si se puede jugar con la expansion y el pack de los mayas y gran colombia en 1.2.4,
Primero desinstalen todo el juego no lo archiven,
Instalen el juego normal
!NO! instalen el new frontier pack solo los archivos (updated)
Despues activen los archivos DLC y listo
—————————————-
Hi!
You can play it with the expansion pack y and Maya & great columbo in 1.2.4,
first of all uninstall all the game data
then install the game
!Do not! install the new frontier pack only the (updated) files
After that activate the DLC and you are done

20200711_163910[1].jpg
Onibaku
Onibaku
5 months ago

Update 1.2.4 , all DLCs, expansion pack installed, confirmed working on atmosphere 0.12 firmware 10.0.2. Thank you admin

Rogelio
Rogelio
5 months ago
Reply to  Onibaku

Can you share your setup? Just atmosphere 0.12?

Bobo
Bobo
5 months ago
Reply to  Onibaku

Hello, can I ask if you installed all of the 10dlc? I keep getting failed to load module. Ive installed the game cleanly like 3 times with the latest nintendo firmware and atmosphere firmware 10. 0.2

Bobby
Bobby
5 months ago
Reply to  Onibaku

Weird, still not working for me, same exact setup, clean install of game.

papeese
papeese
5 months ago
Reply to  Onibaku

Work and playable are two different things though. We all can get the game to load with the DLC/expansion pack and patch 1.2.4, but the game is not playable with the expansion pack enabled.

Last edited 5 months ago by papeese
grosboobs
grosboobs
4 months ago
Reply to  papeese

papeese comment is right. And expansion pack is still not playable with 1.2.5 update

PanicDragon
PanicDragon
28 days ago

Has anyone else had a problem installing the base game? Downloaded the .nsp twice now, but Goldleaf just doesn’t see it. All the DLC and Expansions show up fine, but the base game isn’t in the list.

eunas
eunas
1 month ago

does the torrent contain the latest updates+expansions?

wlaziu
wlaziu
1 month ago

Guys and gals. Do you have Teddy Roosevelt persona pack? The dlcnsp is inside the 5DLC pack (nsp ending with 00C) but it only activates “new frontier pass” as installed.

Pierrick STABLO
Pierrick STABLO
1 month ago

Bonjour, Le jeu en 1.2.7 a beaucoup de bug. Le jeu se ferme sans raison. Les sauvegardes automatiques ne fonctionnent pas. La touche X pour lancer une action ne fonctionne pas. Actuellement dans ma partie, il m’est impossible de passer au tour suivant. Avez-vous également ces problèmes ? Merci. Hello, The game in 1.2.7 has a lot of bugs. The game closes for no reason. Automatic backups do not work. The X key to initiate an action does not work. Currently in my game, it is impossible for me to move on to the next round. Do you also have… Read more »

Nice job
Nice job
1 month ago

This game works great!
Thank you so much!

Update 1.2.7, expansion pack, new frontier pass and all DLC playable with OFW 10.2.0 | AMS 0.14.4.

Last edited 1 month ago by Nice job
Gegs
Gegs
1 month ago

Hello admin.
i can’t install the lastest update, 1.2.7
i already installed the base game and then the dlc packs and then the expansion pack september update. it can run the game. buat when i’m install the 1.2.7 update it always error. i cant open the game
installed from tinfoil
am i missing something? please help me :(((
thanks

received_377821986724653.jpeg
Nice job
Nice job
1 month ago
Reply to  Gegs

You could try re-downloading, re-extraxting or helping the next person help you by telling us your system official firmware version and your custom firmware version.

You may just need an update.

gregfred8
gregfred8
1 month ago

Hello, can you indicate the files that must be taken to have a complete installation up to date?
And the order of installation?
Thank you

CzHuzky
CzHuzky
2 months ago

yeay, finally i can playing civilization VI in update 1.2.7 with expansion pack.
i’m on 10.2.0 version and 0.14.4 atmos

Nice job
Nice job
1 month ago
Reply to  AdminNx

I can, yes.

Nice job
Nice job
1 month ago
Reply to  AdminNx

OFW 10.2.0 | AMS 0.14.4
Update 1.2.7, Expansion pack, New Frontier pass and DLC all playable.

Screenshot_20201008-001056_Gallery.jpg
Jumbuleo
Jumbuleo
2 months ago

Expansion Pack v327680 is out in the wild now and seems to fix all of the previous issues. As in: game starts normally when playing Gathering Storm with latest DLC, which was previously not possible. Can’t guarantee that there are no other errors given this game’s history. But so far so good.

Nice job
Nice job
1 month ago
Reply to  AdminNx

It’s hard to tell if this is correct but:
Install the new expansion pack and update 1.2.7 and the September dlc and we’re all good to go?
Thanks!

Nata
Nata
2 months ago

como seria para instalar el gathering storm y el rise and fall mas los dlcs? cuales puedo usar si quiero tener gathering storm y rise and fall si o si?

maximiliano
maximiliano
2 months ago

hola, hay algún torret que incluya todo?

Everton
Everton
2 months ago

Is there a specific order to install the 5 DLC?
This is what I did:
1 – Install Base game
2- Install 1.27 update (game works fine, without any DLC)
3 – Installed the 5 DLC in random order (then the game start crashing every time)

Everton
Everton
1 month ago
Reply to  AdminNx

Yes, did a fresh re-install of everything in that order. Game with only 1.2.7 works fine, but after installing the 5 DLC (September Update), the switch will throw a error when trying to launch the game.

Everton
Everton
1 month ago
Reply to  AdminNx

I tried those combinations:

Base game > Update 1.2.7 (Game works, without any DLC)

Base Game > 5 DLC (September) > Update 1.2.7 (Game dont start with a error message that says the software was closed because of an error).

Base Game > Expansion Pack Updated > 5 DLC (September > Update 1.2.7 (Same as above happens)

Base Game > Expansion Pack > Update 1.2.7 (same as above happens).

I’m using SXOS (SXCore), installing through USB, not sure if this has something to do with it.

Millions
Millions
1 month ago
Reply to  Everton

Hi dude, I would like to make a suggestion to you: 1-Get a SuperXCI with version 1.2.7+all DLC’s (Maybe you have the same problem I had, the game works but when you try to start a game with additional content, it crashes with the “disable mods” error 2- download the expansion pack(updated september 2020) from this page and build a new version with nscb 3-enjoy! Tip: I did 2 attempts, one with expansion pack + september dlc’s and another one only with expansion pack. At step 2 the first time I get was an xci of 14+Gb, the second time… Read more »

IMG_20201001_094634__01__01.jpg
Wolfun
Wolfun
2 months ago

Im so lost, and im not able to install this :S Could u please explain the packs to download and order to install pls? (im already resetting version with goldleaf but still dont know what to install and the order)

Gegs
Gegs
1 month ago
Reply to  AdminNx

i cant install too.
im on sxos 3.0.5 fw 10.2.0
when i installed the 1.2.7 update. it gives me error everytime i open the game. i don’t know what i missed 🙁

received_377821986724653.jpeg
Millions
Millions
2 months ago

Hola a todos, sigo esta página desde hace tiempo y respeto el trabajo del administrador, no quiero hacer publi de otra página asi que no dire el nombre. Solo comentar que recientemente se ha subido un xci que parece que contiene todo en material de DLC y updates para este juego, lo descargué como tantos otros por probar y para mi sorpresa, funcionó y está todo el contenido activado!

Millions
Millions
2 months ago
Reply to  AdminNx

Aqui tienes la url, ya te comento que desconozco la integridad del resto del contenido de esa página. Yo pillé el xci (base+1.2.7+…) y funciona, aunque no va tan fino como pensé en un principio.

He probado a iniciar partida con los galos en modo gatherin storm, y no tiró.En rise and fall tampoco.

En modo normal si.

Resto de razas del frontier pass, si en modo normal

Voy a probar a actualizar el xci con el frontier pass actualizado y te digo

Millions
Millions
1 month ago
Reply to  AdminNx

Tras actualizar el xci que mencioné, con el frontier pass actualizado, funciona TODO

IMG_20201001_115017_Bokeh__01__01.jpg
Pierrick STABLO
Pierrick STABLO
2 months ago

Bonjour, pouvez-vous donner la marche à suivre fichier par fichier pour installer la 1.2.7 ? Mon jeu plante à chacun de mes essais. Merci 🙂

patientx
patientx
2 months ago

At last everything worked, 1st installed base game, than the 1.2.7 update, than Expansion Pack (Updated) , and lastly DLC Pack (September 2020). Game is latest version, all DLC and expansions are enabled everything is working. Thanks.

Pierrick STABLO
Pierrick STABLO
2 months ago

Bonjour, auriez vous la mise à jour Byzantium et Gaul Pack ? Merci

Arthas91
Arthas91
2 months ago

Hi, do you have a Superxci that works. I have tried different combinations of installing the above and made a mess of things.

Arthas91
Arthas91
2 months ago
Reply to  AdminNx

Hi, Sorry, I got it to work, thank you very much.
I used dbi.nro to reset my required firmware then installed all files. Cheers!

Alexis othily
Alexis othily
2 months ago

please can we have the last uptdate thanks ^^

Nice job
Nice job
2 months ago

Thanks for the update, DLC and expansion!!

Medium Foot
Medium Foot
2 months ago

Base Game (v1.2.6) + All DLC confirmed working on FW10.0.4, installing using Goldleaf v0.8.0.

I can’t get the Expansion Pack to work though. Has anyone had any luck getting the Expansion pack working on 1.2.6? Any recommendations?

Last edited 2 months ago by Medium Foot
Medium Foot
Medium Foot
2 months ago
Reply to  AdminNx

Okay. Thanks!

Just FYI, the names of a lot of the DLC characters are bugged when I’m in game.

  • Maya & grand colombia names/description are bugged
  • Ethiopia doesn’t show up (despite being installed
  • Most of new frontier pack isn’t appearing despite being installed

I am still able to play the game though, so thanks!!

patientx
patientx
2 months ago

I have the game on the sysnand, as in bought from eshop a year ago. I just didn’t have the expansions.When creating emunand it seems, the games latest update -1.2.6- is now known by the emunand and I can’t install the properly with the files posted here. Whatever combo I use, I get error.2002-4153. Whether I install 1.2.6 update or not I get this error and can’t play the game in emunand…. Yes I tried dbi installer to reset game version but it still gives this error whether 1.2.6 is installed or not. Files here are somehow problematic.

pablo
pablo
2 months ago

hello every one, i really like this game but i can´t play the expantions is my first time with a switch and i need some help with the order of each file if someone could help me i will be very happy tnks in advance

Tom
Tom
2 months ago

Is there any chance to have a update file for a patch that is newer than 1.2.6? There are a lot of errors in this version that were fixed in a later version.

Izual
Izual
2 months ago

Hey at fist thx a lot for uploading this game. But cant see the NSP file on my USB Stick. Somebody can help?

Shhhh
Shhhh
3 months ago

The 1.2.5 expansion pack does not work. It says disable mods.but the base game works. Any update on this?

Jumbuleo
Jumbuleo
3 months ago

The reason why update 1.2.5 gives errors is because the DLC packs are outdated and not compatible with version 1.2.5 (current versions are only compatible with 1.2.4). When this game is updated, we do not only need the update file but all updated DLC nsps as well. Reminder: the DLC of this game is integrated into the main game mode, making most of the data depending on each other to be the latest version. This may not be necessary for DLC unlockers (Scenario Pack), but for the New Frontier Pass content and the Rise and Fall + Gathering Storm Expansion… Read more »

nxlichlord
nxlichlord
3 months ago

Awesome! however, there is an error starting game. What should I do about expanation

nxlichlord
nxlichlord
3 months ago
Reply to  AdminNx

when load expanation mod, game will crash. I must close them

nxlichlord
nxlichlord
3 months ago
Reply to  AdminNx

thx for reply. I found that at ver1.25 after loading expanation dlc (which includes gathering storm and the other one) game will crash, but it will go at ver 1.24 and 1.23.

Shhh
Shhh
3 months ago
Reply to  AdminNx

This is what happens when playing the expansion pack. But base game works. The version is 1.2.5.

20200827_135108.jpg
andr3
andr3
3 months ago

Oh holy admin please add the ethiopia expansion pack.

GFDias
GFDias
4 months ago

1.2.5 with the sane mod problem again.They need the DLCs update to work again.

Last edited 4 months ago by GFDias
Alejo
Alejo
4 months ago

Admin sabes si está actualización nueva desbloquea el nuevo DLC de Ethiopía

Alejo
Alejo
4 months ago
Reply to  AdminNx

Hola admin te confirmo e descargado la actualización pero no desbloquea el nuevo pack de Ethiopía podrías subirlo te lo agradecería mucho

Alejo
Alejo
4 months ago
Reply to  AdminNx

Admin te confirmo adicional al agregar el nuevo pack de ethipia creo que debes actualizar nuevamente el pack de fronteras y el pack de expansión ya que el juego como hace unos meses nuevamente crashea o deja de funcionar con la nueva actualización gracias por tu ayuda

Last edited 4 months ago by Alejo
Alejo
Alejo
4 months ago
Reply to  AdminNx

Hola admin gracias por tu colaboración en mi caso dejan de funcionar las expansiones con la nueva actualización no sé si otros usuarios tengan el mismo fallo

Alejo
Alejo
4 months ago
Reply to  AdminNx

Exacto muchas gracias

Alejo
Alejo
4 months ago

Hola admin antes que nada agradecerte por el contenido y tu excelente atención quisiera saber cuándo subes la nueva actualización de civilization gracias

Alejo
Alejo
4 months ago
Reply to  AdminNx

Muchas gracias

Rasmus
Rasmus
4 months ago

Hello. Thank your for the support and updates! The Google Drive Link for update 1.2.4 is broken. It says that I dont have the rights to download

sherks
sherks
4 months ago

Great support . I installed all the links and cannot get this game work with all mods on . “Notes” no very clear

Last edited 4 months ago by sherks
sherks
sherks
4 months ago
Reply to  sherks

i redownload, renamed all (shortening), and it work !!!! Thanks admin for hard work and great support!

Bobby
Bobby
4 months ago

Just wanted to say thanks to adminnx for all your hard work on this.

PorcoRosso
PorcoRosso
4 months ago

A new version of the Expansion Pack is available that doesn’t conflict with the updated 1.2.4 and the new DLC’s (New Frontier), everything is working well again. Can the admin add this new version of the expansion pack for the rest of the users? DM me if you need a reference for the source.

GFDias
GFDias
4 months ago
Probably the expansion pack DLC should have an updated version on Nintendo's servers, since the expansion is 3.7gb.  This file should contain the correction for the error.  The problem is to get this file.  Does anyone have any ideas?
tae
tae
4 months ago
Reply to  GFDias

you can find it , website darksoft. i download it , and work expansion again

Last edited 4 months ago by tae
Rogelio
Rogelio
4 months ago
Reply to  tae

Can you confirm the New Frontier pass, along with The expansion pass is enabled and you can succesfully start a game?

Bobby
Bobby
4 months ago
Reply to  Rogelio

I can’t get the Dark Software version to work with the new frontier pass. Currently only Khmer, Maya, Expansions, and 1.2.4 are working for me but that’s enough for me.

PurpleT
PurpleT
4 months ago
Reply to  tae

website darksoft works, thx to Africa 😉

bobo
bobo
4 months ago
Reply to  AdminNx

hello admin, its here

i tried with tinfoil but it says its a garbage file. i think it works only with goldleaf.

Rogelio
Rogelio
5 months ago

I reinstalled the game with no updates, it runs fine. I then install the 1.2.4 update. It runs fine. I then install the expansion pass (Rise&Fall and Gathering Storm) and the game breaks. It’s a shame, i love this game on switch but it seems to have better anti-piracy meassures than first party Nintendo titles.

Bobby
Bobby
5 months ago
Reply to  Rogelio

Same for me, and a lot of other people in the comments claiming the 1.2.4 update breaks the game the same way as 1.2.3 and only one person claiming it works. I think 1.2.4 is still broken.

Rogelio
Rogelio
5 months ago

I updated and can confirm the issue is still there. This is weird because no one else online are having the issue like with 1.2.3. I will try reinstalling the game and the update without DLC

D.art
D.art
5 months ago

A developer of the game has said on twitter that if you hit + in the Switch menu and then select “Software Update” it should force the correct download to solve mod errors. It seems that solve the problem but for us could be a risk. Maybe there is a way to obtain that hotfix and install offline.

Junayet Miah
Junayet Miah
5 months ago

I am downloading the update 1.2.4 and putting it on my switch. I will edit or reply to this post if I see it fixes the mod issue or not.

Junayet Miah
Junayet Miah
5 months ago
Reply to  AdminNx

Yeah, the update works. Hopefully the issue will get resolved with the DLCs eventually. 🙂 Thank you for uploading these btw!

Locong
Locong
5 months ago

Finally, thanks a lot

locong
locong
5 months ago
Reply to  Locong

CFW 0.10.4 AT 0.13.0,update 1.2.4,DLC:” Khmer” and ” Nubia”… Don’t instal anything related to”new frontier”and”Expansion Pack”

Bobby
Bobby
5 months ago
Reply to  locong

So this doesn’t work with the expansion pack? That’s been the problem with 1.2.3 the whole time. Guess it’s back to 1.2.2 again.

locong
locong
5 months ago
Reply to  Bobby

how do you instal 1.2.2 back without update game nag?

Bobby
Bobby
4 months ago
Reply to  locong

Not possible, the nag will be there but you can still start software if you reset launch version using 0.9dev goldleaf

locong
locong
4 months ago
Reply to  Bobby

Got the link? Is it nro file?

Last edited 4 months ago by locong
Bobby
Bobby
4 months ago
Reply to  locong

google it 0.9dev goldleaf, keep looking its out there

locong
locong
4 months ago
Reply to  Bobby

Thanks

locong
locong
4 months ago
Reply to  Bobby

Been looking for days, no luck to find nsp or nro file,thanks any way

Bobby
Bobby
4 months ago
Reply to  locong

No longer needed, just get the 1.2.4

Locong
Locong
4 months ago
Reply to  Bobby

Can’t download anymore

locong
locong
4 months ago
Reply to  AdminNx

Trying to go back to update 1.2.2 just to play gathering Strom expansion ,need 0.9dev goldleaf,found the site but can’t download the goldleaf, sorry for your trouble,thanks

You201
You201
5 months ago

the update did not fix the mods issue

Bobo
Bobo
5 months ago
Reply to  AdminNx

Hello admin, do you think in that case it will ever be fixed? We have to wait for them to fix it right?

PorcoRosso
PorcoRosso
5 months ago
Reply to  AdminNx

I can confirm that this update 1.2.4 breaks the game again as in 1.2.3 even without installing the New Frontier DLC.
Admin, please remove this update before other people break their game also.

PorcoRosso
PorcoRosso
5 months ago
Reply to  AdminNx

Yes, it works with 1.2.4 but you can’t use the DLC’s.

Bobo
Bobo
5 months ago
Reply to  AdminNx

Yes my one says failed to load module

Bobby
Bobby
5 months ago
Reply to  AdminNx

The whole time the problem has been related to DLC (expansion pack). 1.2.3 would fail to load module with the expansion pack enabled but worked fine with it turned off. Same exact issue with 1.2.4, this feels like some sort of new copy protection.

Bobby
Bobby
5 months ago
Reply to  AdminNx

Yes, this problem is due to an outdated version of the expansion pack (V0). The official version is on (V2). Lots of discussion here and on Reddit, it appears that 1.2.3 and 1.2.4 need the newer version of the expansion, but 1.2.2 doesn’t. So currently the best way to play this game is on 1.2.2, 1.2.4 will not work with expansion pack v0.

Bobby
Bobby
4 months ago
Reply to  AdminNx

010044500C183003

Bobby
Bobby
4 months ago
Reply to  AdminNx

expansion title id

Bobby
Bobby
4 months ago
Reply to  AdminNx

Just wanted to let you know there is an updated version of the expansion pack available from African on the Dark Software Forums, I’ve tested it myself and it works with 1.2.4.

Rogelio
Rogelio
5 months ago

Just a heads up, There´s gonna be an update this week, if you could upload it please. I think it goes live tomorrow.

Rogelio
Rogelio
5 months ago
Reply to  AdminNx

Thanks!, The Gdrive link seems to be broken.

papeese
papeese
5 months ago
Reply to  AdminNx

update still doesn’t work with the expansion pack

Bobby
Bobby
5 months ago
Reply to  AdminNx

The 1.2.3 update also worked without the expansion, the problem is the same.

D.art
D.art
5 months ago
Reply to  AdminNx

Hi! First of all. Thank you for the hard work. I appreciate the effort. However it seems to be a problem with update 1.2.4. The nsp it is not recognized by the sx os. I’d like to know if it only happens to me. Thanks  

Bobo
Bobo
5 months ago
Reply to  D.art

Rename the file to something shorter and it will appear

Locong
Locong
5 months ago

Do you know how to make the game start with out asking for update, it was 1.2.3 ver and I installed the 1.2.2 ver back

Locong
Locong
5 months ago
Reply to  AdminNx

Sorry for your trouble, could you tell me step by step to do it, been trying to “reset launch version” using goldleaf v 0.8 doesn’t work, someone said need to use goldleaf v0.9-dev but can’t find that 0.9 version

PorcoRosso
PorcoRosso
5 months ago

Any news on the fix?

Acti0nMac
Acti0nMac
5 months ago

Hi. Can you upload the 1.2.2 update while we wait for the 1.2.3 hotfix?

Acti0nMac
Acti0nMac
5 months ago
Reply to  AdminNx

Thank you so much. 😀

andr3
5 months ago

Tinfoil.io shows the expansion pack dlc as a V1, so maybe the Hotfix was there and not a different update, this has happened before with Xenoblade 2 because it had different versions of dlcs. Is the expansion pack dlc the V1 mentioned on Tinfoil.io or is it the V0?

Bobo
Bobo
5 months ago

Pleqse please can we have a estimate guess on the working patch 1.2.3?

Bobo
Bobo
5 months ago
Reply to  AdminNx

Thank you so much

Subsided
Subsided
5 months ago

The Expansion pass seems to be a junk file, wont let it be installed on SX Installer calling it junk and when i install it through the default installer it still starts but when i try and start the game it will have an error, only once i disable the expansion content can i play it normally. Seems all around poo poo