Wolfenstein Youngblood Deluxe Edition Switch NSP + Update + DLCs

Wolfenstein Youngblood Deluxe Edition Switch NSP

Title: Wolfenstein Youngblood Deluxe Edition NSP
Release Date:Jul 26, 2019
Category: Action, First Person
Publisher: Bethesda Softworks
Format: NSP
Title ID: 01003BD00CAAE000
Title Size: 20.5 GB
Language: En, Fr, De, It, Es
Multiplayer: Up to 2 Players
Required Firmware: 8.1.0
CFW: 8.1.0 + Atmosphere 0.9.2

Loading...

Wolfenstein Youngblood NSP is the first modern co-op Wolfenstein adventure developed by MachineGames and published by Bethesda Softworks,

Description: Nineteen years after the events of Wolfenstein II, BJ Blazckowicz has disappeared after a mission into Nazi-occupied Paris. Now, after years of training from their battle-hardened father, BJ’s twin daughters, Jess and Soph Blazkowicz, are forced into action. Team up with a friend or play alone. Level up, explore, and complete missions to unlock new abilities, weapons, gadgets, cosmetics, and more to complement your playstyle and customize your appearance. Wolfenstein: Youngblood features the most open-ended Wolfenstein experience to date. From a new base of operations located deep in the heart of the Paris catacombs, plan how and when to attack and dismantle the Nazi regime.

Wolfenstein: Youngblood is a brand-new co-op adventure from award-winning studio MachineGames, developers of the critically-acclaimed Wolfenstein II: The New Colossus, in partnership with Arkane Studios Lyon. Play as one of BJ Blazkowicz’s twin daughters and undertake a do-or-die mission to find their missing father in 1980s Paris. Wield an arsenal of new weapons, gadgets, and power armor abilities in a fight to kick Nazis out of the city of lights. Paris 1980. BJ Blazkowicz, hero of the second American Revolution, is missing.

How to Install, Update and Unlock the Game?

  1. Unrar all compressed files to a folder. (Game NSP, Update 1.1 and DLCs + Unlocker)
  2. First, Install the base game NSP to your Internal storage or SD card.
  3. After base game install the Update 1.1.0 NSP.
  4. Now install the Pre Order and Deluxe DLCs.
  5. After DLCs Install the DLC Unlock 1 and DLC Unlock 2 files.
  6. Once all installations are done you will be able to play the game and there will be no need of Bathesda account.

Download Links

Base Game NSP (20.6 GB) (Pre Order + Deluxe Edition DLCs Included)

Please see the above Insllation Tutorial. This game need FW 8.1.0 its unplayable on FW 7.0.1 or 8.0.1.

MEGA
Part1, Part2, Part3, Part4

Google Drive
Part1, Part2, Part3, Part4

1Fichier
Part1, Part2, Part3, Part4

Update 1.1.0 (v65536)

Update 1.3.0 (v196608)

DLCs + Unlocker

Please report the broken/dead/missing links into the comment section.

Share

You may also like...

80 Responses

  1. Mustafa says:

    Thanks for this, but the update links are down.

  2. Ale says:

    very thanks

  3. Azure says:

    When I install the game it tells me that it is the buddy version, it doesn’t let me play without the bethesda account. Any solution?

  4. angel says:

    i can’t extract it, somebody else?

  5. chucho says:

    It gives me an error when starting the game maybe it was decompressed badly, I had that problem with MK I downloaded it twice in different places and I noticed by difference of bytes the game will have failures, this game has 22,081,221,184 bytes, I don’t know if you have others data. I used a translator I don’t speak English XD

  6. Eric says:

    when i install both the base and update …i get in and then this error appears “Unable to start software. Return to Home screen”…any idea what’s wrong please ?

  7. Nguyen Huy says:

    entered the game but could not play. No betheda account

  8. Nguyen Huy says:

    Note: this is the trial version of wofenstein Youngblood. In order to play, you will need a linked Bethesda.net account and receive an invite from your buddy owns the Buddy pass

  9. Christian says:

    Hi, Thanks for the upload.
    I can´t open the game;
    Reinx 2.4
    Firmware 8.0.1
    Installing with goaldleaf 0.5 – with “yes” on the “ignore firmware requirement”.
    1- I´m installing the base game
    2- instaling dlc
    3- installing other dlc
    4 – installing Update 1.1.0
    5- try to open the game. Get message; PROGRAM CLOSED DUE TO AN ERROR.
    I´ve tried to install only base game – same error.
    Also tried base game + dlcs (without update) : same error
    Also base game + only update : same eror.
    I´ve never had this error installing any other nsp…
    Am I the only one?
    Any help please?
    BIG THANKS 😀

    • AdminNx AdminNx says:

      See the above how to install Tutorial.

      Furthermore, this game need Firmware 8.1.0 its unplayble @ 8.0.1 i my self was testing it on 7.0.1 and 8.0.1 but not worked. Even the update 1.1 needs the latest firmware which is 8.1.0.

      After following the above tutorial i am able to play the game.

      • Christian says:

        Ok, thanks so much… I’ll have to update then. Thanks. I love your page, you upload everything MUCH faster than many other! Cool

        • AdminNx AdminNx says:

          Thanks mate for appreciation. Sorry for bit late response in this was testing it my self thats why got bit late.

          • asdf says:

            Have the same problem: install works, on start exit with err…
            I have already 8.1.0 (AMS 0.9.2)

            What to do now?

          • AdminNx AdminNx says:

            Have you followed the above installation tutorial one by one?
            What error you are getting?

          • asdf says:

            My error is the same as from the guy aboe who is not on 8.1.0 “PROGRAM CLOSED DUE TO AN ERROR.” in white letters on black screen with an exclamation mark in the middle…

            But i have definitely 8.1.0 …

          • AdminNx AdminNx says:

            This seems like an error of installation.
            May i know what CFW you are using and whats you CFW version?
            second, uninstall the whole game and just install the base game (don’t update or put DLCs) and try to launch it again.

          • asdf says:

            hekate v5.0.1 & Nyx v0.8.1
            ams 0.9.2

            i have the sig patch pack 2.0.0-8.1.0 from gbatemp installed

            get to the menu now, but it says there: “title store not found pls redownload”

            maybe the DLCs are the problem? when trying to install either dlc or unlock using goldleaf 0.5 i always get:
            error 0x234c02
            module fs(2)
            incalid nca (4518)

            had this also with mortal kombat and terraria, but with all my other 70+ games it worked flawlessly…
            thats why i am so confused, why just these games?

          • asdf says:

            also noticed that in goldleaf 0.5 for some titles it displays in the overview, just before installing under the title key, something like: “key generation: version 9 (unknown)”

            This is also with wolfyb the case…

            But also had this displayed for some titles and they worked after the installation, so maybe this has nothing to do with it…?

          • AdminNx AdminNx says:

            Can you install via Gold Tree 0.5 via USB method?

          • asdf says:

            Will try that, but have to buy a usbc cable first

          • asdf says:

            Did not work either
            base game and update installable but not playble,
            dlcs and unlocks not even installable
            just like before, with the same errors

          • AdminNx AdminNx says:

            Whats your OFW and CFW versions?
            What medium and app you are using for installation?

          • asdf says:

            hekate v5.0.1 & Nyx v0.8.1
            ams 0.9.3
            fw 8.1.0

            Did another try today, still not working.
            Base and update installable.
            Both DLCs and both Unlockers throw Invalid NCA.
            Enabled “install unsigned code” in TF.
            Unlocker and DLCs installable now.
            When starting game the system says “corrupted data found”, probably because of unsigned installation?!
            When doing the check which the system offers it ends with “SD is corrupted”…
            The game is definitely installed, about ~22gb more used now.
            I hate checksums!!! -.-
            Also my inet and storage are stable! Already redownloaded and also tried other sources, still not working.

            I did not check reinstall nca’s to yes, should i try it again with that to yes?
            Or what esle could work?

          • AdminNx AdminNx says:

            Ok there are few things i like to know, do you have Kosmos pack installed with Atmosphere 0.9.3? If you have Kosmos or have installed the Kosmos please also copy these patches http://1link.club/3401

            I suggest do a complete clean install by following below steps.
            1. Uninstall whole game, update, dlcs everything related to Youngblood
            2. Install base, then update, then preorder and deluxe dlcs, and last unlock 1 and unlock 2 DLCs.

            Furthermore, i also like to know do you have Nintendo Linked account installed?

          • asdf says:

            I dont have kosmos.
            I followed the nh guide (https://nh-server.github.io/switch-guide/user_guide/emummc/sd_preparation/), so i only have ams hekate ftpd lockpickrcm nxtheme/shell and checkpoint. I later added edizon and goldleaf manually…
            I already installed the patches that you linked.
            Also i tried installing it multiple times, i dont think that just trying it again without changing anything will make a difference…

          • AdminNx AdminNx says:

            Are you encountering same error with any other game? are you on our discord server?

          • asdf says:

            What is a nintendo linked account?
            I was once in the eshop to download youtube, maybe i had to create an account, cant remember…

          • AdminNx AdminNx says:

            This was a security layer added by Nintendo in past days to play games. Some games like Bloodstained: Ritual of the nights and Mortal Kombat 11 updates after v1.03 needs a Nintendo Linked ID in order to play. Its not a hard thing you can install it very easily with Kefir Updater.

          • asdf says:

            Uhhh! that sounds promising 🙂
            Yes, i already had this with veeeery few other games:
            – Terraria
            – MK11
            – My friend pedro
            – and ofc Wolf
            – (there might have been few others, but about these i was most angry that they didnt work)

            Its been a while since i bought and set up my switch, so i cant remember, but might be that i unlinked the acc after having DL-ed YT from the eshop. Actually its very possible, im sure i used the shop only onced (for youtube), also i dont play online now and i never have played online in the past. I use my switch only in CFW mode thats why i stay away from everything related to nintendo….

            No, im not your discord, whats the link?

          • AdminNx AdminNx says:

            I suggest if you can put Kosmos or give a try to ReinX that might resolve your issues. I never encountered such errors on ReinX and Atmosphere + Kosmos combo.
            Furthermore, you can join Discord channel by visiting this link https://discordapp.com/invite/rwcA4TP

          • asdf says:

            Damn i just check in both stock and emu cfw.
            There is no “Link to nint acc” in the user settings…
            Instead there is a “Check nintendo account settings”, so i guess its linked then?

          • AdminNx AdminNx says:

            If you have Emunand than please create a ReinX compatible CFW and then install the game there and try to play. Its only you in the list who has issues with game.

          • asdf says:

            When i go to eshop settings in stock sys it says nintendo switch online: no membership, no coupons…

            Is such a membership required?

            Pls post the discord link, i dont want to spam the comments any more xD

        • asdf says:

          when just installing only the main game it does not start with the hint that an update is required

          there is no option to skip that (which i have in some of my other games), only “cancel” and “download”

  10. denny torres says:

    Amazingggg playing perfecttt thank youuuuu very much

  11. gess says:

    working great on reinx 8.0.0 using goldleaf 0.5 and following the tutorial ,thank u. 🙂

  12. Eqxile says:

    how to change laguage?

  13. armando says:

    funciono mil gracias es la mejor paguina que e encontrado una peticion mira tengo el ultra street fighter 2 y es el unico que no me arranca me sale el error de archivo dañados e leido algo de que hay caracteres que switch no puede leeer podrias subirlo por favor gracias

  14. luis says:

    ola mira quiero confirmar que ese tutorial funciona perfectmente lo unico que quiero apuntar es que tengo el firmware 8.0.1 y funciina a la pefeccion gracias crack

  15. Bluehaze says:

    It works with the DLC Tutorial above. Thanks

  16. nono says:

    ola administrador yo tambien confirmo que funciona en 8.0.1 esa actualisacion se la instale y me funciona gracias crack

  17. trek says:

    Hola Admin

    Para reportar hay links caidos
    One Link –> Google Drive
    DLCs + Unlocker –> Google Drive

  18. lozio says:

    hi, i installed the game follwing the guide “how to install”, but the game at the start required internet connection!! Why ?
    How i can connect swtich to internet prevent the danger of ban?

    Thanks to all

  19. Mark says:

    hi.
    this game as i know have patch version 1.04, 1.05 , 1.06 too.

    please if its possible put them for download too , or at least tell me how can i download them ?

    Thanks a lot !!!! 😀

    • AdminNx AdminNx says:

      Update version 1.0.3 (1966068) is the last version which released on Switch. You must be seeing higher version on PC.

      • Mark says:

        oh.. yes , youre right.
        so do you know how can i fix 1 crash ?
        in game while grabbing floopy or documents or etc , and when i have to press “E” in game it will jump out and say this:
        #str_dlg_error_game
        ERROR: No free managed instance, see the entity_list_txt for details.

        i did everything like new crack , low graphic and ets but not gonna work.

        how can i fix it ?

        thnaks so much 🙂

  20. Malik says:

    Hola estoy en la version 9.0.0 y cuando abro el juego me sale esto…
    ¨Please turn Airplane Mode off when appriate for your sorroundings”

    saben como reparar esto?
    ayuda porfa :”(

  21. Maja says:

    Please help
    Thank you

  22. opeo says:

    The links are taking me to another 1link.com.Is it broken?

Leave a Reply

Your email address will not be published. Required fields are marked *